Currently experiencing intermittant issues
Incident Report for LassoCRM
Resolved
The issue has been resolved.
Posted about 3 years ago. Mar 10, 2016 - 12:28 PST
Identified
The issue has been identified and we're working to resolve the issue as quickly as possible.
Posted about 3 years ago. Mar 10, 2016 - 12:19 PST
Investigating
We are currently investigating this issue.
Posted about 3 years ago. Mar 10, 2016 - 12:09 PST