System Interruption
Incident Report for LassoCRM
Resolved
Lasso is back to normal operation. We apologize for the interruption.
Posted over 2 years ago. Nov 24, 2016 - 16:51 PST
Identified
We've identified the issue and are working to resolve it.
Posted over 2 years ago. Nov 24, 2016 - 16:39 PST
Investigating
We're currently investigating the service interruption.
Posted over 2 years ago. Nov 24, 2016 - 16:31 PST