Intermittant issues
Incident Report for LassoCRM
Resolved
We isolated the issue that was causing the intermittent issues. Back to normal operations.
Posted over 3 years ago. Feb 19, 2016 - 12:08 PST
Investigating
We are experiencing intermittent issues. We are currently investigating.
Posted over 3 years ago. Feb 19, 2016 - 10:57 PST